 <!DOCTYPE html>
<html lang="en">
<head>
<title>Obituary for Elizabeth  J. Reagan , Fayetteville , AR</title>
<link rel="apple-touch-icon" sizes="57x57" href="//media.arkansasonline.com/static/ao_redesign/dist/img/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="//media.arkansasonline.com/static/ao_redesign/dist/img/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="//media.arkansasonline.com/static/ao_redesign/dist/img/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="//media.arkansasonline.com/static/ao_redesign/dist/img/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="//media.arkansasonline.com/static/ao_redesign/dist/img/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="//media.arkansasonline.com/static/ao_redesign/dist/img/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="//media.arkansasonline.com/static/ao_redesign/dist/img/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="//media.arkansasonline.com/static/ao_redesign/dist/img/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="//media.arkansasonline.com/static/ao_redesign/dist/img/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="//media.arkansasonline.com/static/ao_redesign/dist/img/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="//media.arkansasonline.com/static/ao_redesign/dist/img/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="//media.arkansasonline.com/static/ao_redesign/dist/img/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="//media.arkansasonline.com/static/ao_redesign/dist/img/favicon-16x16.png">

<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="//media.arkansasonline.com/static/ao_redesign/dist/img/ms-icon-144x144.png">
<meta name="theme-color" content="#333333">
<meta name="apple-mobile-web-app-title" content="Northwest Arkansas Democrat-Gazette">
<meta name="application-name" content="Northwest Arkansas Democrat-Gazette">
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no" />
<meta http-equiv="X-UA-Compatible" content="ie=edge" />
<meta name="description" content="NWADG.com is the premier digital source for news in Fayetteville, Springdale, Rogers, Bentonville and surrounding areas in Northwest Arkansas. Featuring content from the Northwest Arkansas Democrat-Gazette" />
<style>
	.latest__article {
		align-self: self-start;
	}
</style>
<script>
window.dataLayer = window.dataLayer || [];
window.dataLayer.push({
    'event': 'dataLayer-loaded',
    'author': 
                  
                    ''
                  
                ,
    'articleCategory': 
                            ''
                        ,
    'contentType': 
            ''
           ,
    'contentPublishDate': 
                            
                                ''
                            
                          ,
    'companyName': 'NWADG',
    'contentPublishedDayOfWeek':  
                   ''
                 ,
    'subdomain': '',
    'articleTitle': 
                            ''
                     
})
</script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KXMHKG');</script>

<script type="text/javascript">
var dfpAdunit = 'nwa/nwadg/news/obituary';
</script>

<script type="text/javascript">
/* A9 Load Lib */
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function()
{q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(
A,g)}("apstag",window,document,"script","https://c.amazon-adsystem.com/aax2/apstag.js");
</script>
<script type="text/javascript">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</script>
<script type="text/javascript" async="true" src="https://media-cdn.wehco.com/vendors/nwadg/prebid/prebid.js"></script>

<script type="text/javascript" async src="https://media.arkansasonline.com/static/nwa_redesign/dist/js/prebid.js"></script>

<script src="//cdn.blueconic.net/wehco.js"></script>
<script type="text/javascript">var bcTagged = true;</script>

<style>
.breaking-news__text a, .breaking-news__text a:hover { color: #fff; }
</style>
<link rel="stylesheet" type="text/css" media="all" href="https://media.arkansasonline.com/static/nwa_redesign/dist/css/styles.css" />
<link rel="stylesheet" type="text/css" media="all" href="https://media.arkansasonline.com/static/nwa_redesign/dist/css/newseditor.css" />
<style type="text/css">
table.tablesorter {
  width: 100%;
  margin-top: 20px;
    padding-bottom: 2rem;
    margin-bottom: 2rem;
    border-bottom: .0625rem #ececec solid;  
}
thead {
    display: table-header-group !important;
    vertical-align: middle;
}
th { display: table-cell; border-bottom: .0625rem #ececec solid;  border-top: .0625rem #ececec solid; padding-bottom: 4px; padding-top: 3px; }
td { padding-right: 10px; }
.deceased-name {
font-weight: 700;
font-size: 1.25rem;
font-family: "Source Serif Pro",serif;
width: 46%;
}
.deceased-age {
}
.deceased-location {
width: 20%;
}
.deceased-date {
width: 15%;
}
.deceased-sort {
width: 68px !important;
max-width: 68px !important;
}

@media screen and (max-width: 780px) {
.deceased-name {
font-weight: 700;
font-size: 1rem;
font-family: "Source Serif Pro",serif;
}
  }

@media screen and (max-width: 415px) {
table, .deceased-name {
font-size: .75rem;
}
.deceased-name {

}
  }
</style>
</head>
<body>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KXMHKG"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<header>
<div class="header">
<div class="header__menu-and-search">
<div class="header__menu">
<span class="header__menu-btn">
<svg class="header__menu-icon" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink" x="0px" y="0px" viewbox="0 0 12 10" style="enable-background:new 0 0 12 10;" xml:space="preserve">
<path class="bottom" d="M11.7,10H0.3C0.1,10,0,9.9,0,9.7V8.9c0-0.2,0.1-0.3,0.3-0.3h11.4c0.2,0,0.3,0.1,0.3,0.3v0.9C12,9.9,11.9,10,11.7,10z"></path>
<path class="top" d="M11.7,1.5H0.3C0.1,1.5,0,1.3,0,1.1V0.3C0,0.1,0.1,0,0.3,0h11.4C11.9,0,12,0.1,12,0.3v0.9C12,1.3,11.9,1.5,11.7,1.5z"></path>
<path class="middle" d="M11.7,5.8H0.3C0.1,5.8,0,5.6,0,5.4V4.6c0-0.2,0.1-0.3,0.3-0.3h11.4c0.2,0,0.3,0.1,0.3,0.3v0.9C12,5.6,11.9,5.8,11.7,5.8z"></path>
</svg>
<span class="header__menu-btn-text">Sections</span>
</span>
</div>
<div class="header__search-desktop">
<form name="ao_search2" id="ao_search2" action="/search/">
<div class="btn--search">
<i class="fa fa-search"></i>
</div>
<div class="search-input__active">
<i class="fa fa-search"></i>
<input type="text" placeholder="search" type="text" value="" name="query" id="id_query">
</div>
</form>
</div>
<nav class="nav__header">
<div class="nav__header-search">
<form name="ao_search3" id="ao_search3" action="/search/">
<div class="nav__header-search-group">
<input class="nav__header-search-input" type="text" value="" name="query" id="id_query">
<button class="nav__header-search-btn">
<em class="fas fa-search fa-lg"></em>
</button>
</div>
</form>
</div>
<div class="menu nav__header-menu">
<div class="nav-list nav__header-menu-item">
<span class="nav-list-header nav__header-menu-text">News
<em class="caret fas fa-angle-down"></em>
</span>
<ul class="nav-submenu nav__header-sub-menu">
<li>
<a href="/arkansas/northwest/?page=1" title="Local">Local</a>
</li>
<li>
<a href="/arkansas/" title="State">State</a>
</li>
<li>
<a href="/national/" title="National">National</a>
</li>
<li>
<a href="/world/" title="World">World</a>
</li>
<li>
<a href="/weather/" title="World">Weather</a>
</li>
<li>
<a href="/obituaries/" title="Obituaries">Obituaries</a>
</li>
<li>
<a href="/email/" title="Newsletters">Newsletters</a>
</li>
<li>
<a href="/archivesearch/" title="Archive Search">Archive Search</a>
</li>
</ul>
</div>
<div class="nav-list nav__header-menu-item">
<span class="nav-list-header nav__header-menu-text">Sports</a>
<em class="caret fas fa-angle-down"></em>
</span>
<ul class="nav-submenu nav__header-sub-menu">
<li>
<a href="/sports/prep/" title="Prep">Prep</a>
</li>
<li>
<a href="/sports/college/" title="College">College</a>
</li>
<li>
<a href="/sports/pro/" title="Professional" target="_blank">Professional</a>
</li>
<li>
<a href="/outdoors/" title="Outdoors">Outdoors</a>
</li>
<li>
<a href="/sports/razorbacks" title="Razorbacks" target="_blank">Razorbacks</a>
</li>
<li>
<a href="/staff/wally-hall/" title="Wally Hall" target="_blank">Wally Hall</a>
</li>
</ul>
</div>
<div class="nav-list nav__header-menu-item">
<span class="nav-list-header nav__header-menu-text">
Business
<em class="caret fas fa-angle-down"></em>
</span>
<ul class="nav-submenu nav__header-sub-menu">
<li>
<a href="/business/arkansas/northwest/" title="Local">Local</a>
</li>
<li>
<a href="/business/arkansas/" title="State">State</a>
</li>
<li>
<a href="/business/national/" title="National">National</a>
</li>
<li>
<a href="/business/arkansas/northwest/walmart/" title="Walmart">Walmart</a>
</li>
</ul>
</div>
<div class="nav-list nav__header-menu-item">
<span class="nav-list-header nav__header-menu-text">Media
<em class="caret fas fa-angle-down"></em>
</span>
<ul class="nav-submenu nav__header-sub-menu">
<li>
<a href="http://nwamedia.photoshelter.com/" title="Photos">Photos</a>
</li>
<li>
<a href="http://nwamedia.photoshelter.com/gallery-collection/Society/C0000CChWcp2.h7o" title="Society galleries">Society galleries</a>
</li>
<li>
<a href="http://nwamedia.photoshelter.com/gallery-collection/High-School-Sports/C000037iUYrvFc_Q" title="Prep Galleries">Prep Galleries</a>
</li>
<li>
<a href="http://nwamedia.photoshelter.com/gallery-collection/Razorback-Sports/C0000iQzyYYlYP.Q" title="Razorbacks Galleries">Razorbacks Galleries</a>
</li>
<li>
<a href="/video/" title="Videos">Videos</a>
</li>
<li>
 <a href="/sponsorcontent/?ntv_adpz=3457" title="Ask An Expert">Ask An Expert</a>
</li>
<li>
<a href="/podcast/" title="Podcasts">Podcasts</a>
</li>
<li>
<a href="/nwtablethelp/" title="Tablet Help">Tablet Help</a>
</li>
<li>
<a href="/cooking/" title="Cooking">Cooking</a>
</li>
</ul>
</div>
<div class="nav-list nav__header-menu-item">
<span class="nav-list-header nav__header-menu-text">
Opinion
<em class="caret fas fa-angle-down"></em>
</span>
<ul class="nav-submenu nav__header-sub-menu">
<li>
<a href="/opinion/northwest" title="Local">Local</a>
</li>
<li>
<a href="/opinion/" title="State">State</a>
</li>
<li>
<a href="/staff/fran-alexander/" title="Fran Alexander">Fran Alexander</a>
</li>
<li>
<a href="/staff/brenda-blagg/" title="Brenda Blagg">Brenda Blagg</a>
</li>
<li>
<a href="/staff/john-brummett/" title="John Brummett">John Brummett</a>
</li>
<li>
<a href="/staff/art-hobson/" title="Art Hobson">Art Hobson</a>
</li>
<li>
<a href="/staff/mike-masterson/" title="Mike Masterson">Mike Masterson</a>
</li>
<li>
<a href="/staff/hoyt-purvis/" title="Hoyt Purvis">Hoyt Purvis</a>
</li>
<li>
<a href="/staff/lowell-grisham/" title="Lowell Grisham">Lowell Grisham</a>
</li>
<li>
<a href="/staff/greg-harton/" title="Greg Harton">Greg Harton</a>
</li>
<li>
<a href="/staff/gary-smith/" title="Gary Smith">Gary Smith</a>
</li>
<li>
<a href="/staff/doug-thompson/" title="Doug Thompson">Doug Thompson</a>
</li>
<li>
<a href="/staff/woody-bassett/" title="Woody Bassett ">Woody Bassett</a>
</li>
<li>
<a href="/staff/ted-talley/" title="Ted Talley">Ted Talley</a>
</li>
<li>
<a href="/submit/letter/" title="Submit Letter to the editor">Submit Letter to the editor</a>
</li>
</ul>
</div>
<div class="nav-list nav__header-menu-item">
<span class="nav-list-header nav__header-menu-text">Features
<em class="caret fas fa-angle-down"></em>
</span>
<ul class="nav-submenu nav__header-sub-menu">
<li>
<a href="/northwestprofiles/" title="Northwest Profiles">Northwest Profiles</a>
</li>
<li>
<a href="/ourtown/" title="Our Town">Our Town</a>
</li>
<li>
<a href="/features/moviestyle/" title="Movie Style">Movie Style</a>
</li>
<li>
<a href="/religion/" title="Religion">Religion</a>
</li>
<li>
<a href="/whatsup/onstage/" title="On Stage">On Stage</a>
</li>
<li>
<a href="/features/whatsup/" title="What’s Up">What’s Up</a>
</li>
<li>
<a href="https://www.getoutintheozarks.com/" title="Get Out in the Ozarks">Get Out in the Ozarks</a>
</li>
<li>
<a href="/features/family/" title="Family">Family</a>
</li>
<li>
<a href="/features/food/" title="Food">Food</a>
</li>
<li>
<a href="/restaurantinspections/" title="Restaurant Inspections">Restaurant Inspections</a>
</li>
<li>
<a href="/style/" title="Style">Style</a>
</li> 
<li>
<a href="/features/homestyle/" title="Home Style">Home Style</a>
</li>
<li>
<a href="/features/activestyle/" title="Active Style">Active Style</a>
</li>
<li>
<a href="https://celebrations.nwaonline.com/" title="Celebrations">Celebrations</a>
</li>
<li>
<a href="/puzzles/" title="Puzzles">Puzzles</a>
</li>
<li>
<a href="/dining/" title="Dining">Dining</a>
</li>
</ul>
</div>
<div class="nav-list nav__header-menu-item">
<span class="nav-list-header nav__header-menu-text">
Columnists
<em class="caret fas fa-angle-down"></em>
</span>
<ul class="nav-submenu nav__header-sub-menu">
<li>
<a href="/staff/lisa-kelley/" title="Lisa Kelley">Lisa Kelley</a>
</li>
<li>
<a href="/staff/becca-martin/" title="Becca Martin">Becca Martin</a>
</li>
<li>
<a href="/staff/carin-schoppmeyer/" title="Carin Schoppmeyer">Carin Schoppmeyer</a>
</li>
<li>
<a href="/staff/philip-martin/" title="Philip Martin">Philip Martin</a>
</li>
<li>
<a href="/staff/sey-young/" title="Sey Young">Sey Young</a>
</li>
<li>
<a href="/staff/gwen-rockwood/" title="Gwen Rockwood">Gwen Rockwood</a>
</li>
<li>
<a href="/staff/tom-dillard/" title="Tom Dillard">Tom Dillard</a>
</li>
</ul>
</div>
<div class="nav-list nav__header-menu-item">
<span class="nav-list-header nav__header-menu-text">Marketplace
<em class="caret fas fa-angle-down"></em>
</span>
<ul class="nav-submenu nav__header-sub-menu">
<li>
<a href="http://marketplace.nwaonline.com/marketplace/" title="Classifieds">Classifieds</a>
</li>
<li>
<a href="http://www.nwajobfinder.com/" title="Jobs">NWA Job Finder</a>
</li>
<li>
<a href="https://www.jobsarkansas.com/" title="Jobs Arkansas">Jobs Arkansas</a>
</li>
<li>
<a href="http://www.nwahomes.com/" title="Homes">Homes</a>
</li>
<li>
<a href="http://www.autosarkansas.com/" title="Autos">Autos</a>
</li>
<li>
<a href="/eventhub/" title="Events">Events</a>
</li>
<li>
<a href="https://www.nwadealpiggy.com/" title="Deal Piggy">Deal Piggy</a>
</li>
<li>
<a href="/circulars/" title="Circulars">Circulars</a>
</li>
<li>
<a href="/advertising/" title="Advertising">Advertising</a>
</li>
<li>
<a href="https://promotions.nwadg.com/" title="Advertising">Contests</a>
</li>
<li>
<a href="https://texttaponit.com/nwarkansas?utm_source=wehco&utm_medium=email" title="TapOnIt">TapOnIt Mobile Deals</a>
</li>
<li>
<a href="/advertising/" title="Print and Digital Advertising">Print and Digital Advertising</a>
</li>
<li>
<a href="/specialsections/" title="Specials">Special Sections</a>
</li>
</ul>
</div>

</div>
</nav>
</div>
<a class="header__link" href="//nwaonline.com" title="Northwest Arkansas Democrat-Gazette"><img class="header__logo--nwadg" src="//media.arkansasonline.com/static/nwa_redesign/dist/img/nwadg-logo.svg" alt=""></a>
<div class="settings">
<div class="settings__group-for-mobile"><em class="fas fa-user-circle settings__mobile-icon"><span class="settings__signed-in-text"><i class="fas fa-caret-down"></i></span></em>
<div class="settings__mobile">
<a class="btn full-width" href="/auth/login?r=//www.nwaonline.com/obituaries/2020/nov/22/elizabeth-reagan-2020-11-22/">Sign&nbsp;in</a>
<a class="btn btn--subscribe btn--full-width" href="/subscribe/">Subscribe</a>
</div>
</div>
<div class="settings__group-for-desktop">
<a class="btn btn--sign-in" href="/auth/login?r=//www.nwaonline.com/obituaries/2020/nov/22/elizabeth-reagan-2020-11-22/">Sign&nbsp;in</a>
<a class="btn btn--subscribe-header" href="/subscribe/">Subscribe</a>
</div>
</div>
</div>
</div>
</div>
</header>
<div class="subheader">
<a class="subheader__link--e-edition" href="/auth/login?r=eedition" title="title">
<em class="fas fa-newspaper"></em>Today's Paper</a>
<a class="subheader__link" href="https://www.nwaonline.com/nwdigital/faq/" title="Digital FAQ">Digital FAQ</a>
<a class="subheader__link" href="/obituaries/" title="Obits">Obits</a>
<a class="subheader__link" href="https://www.nwaonline.com/email/" title="Newsletters">Newsletters</a>
<a class="subheader__link" href="https://www.nwaonline.com/nwavote/" title="✅NWA Vote">✅NWA Vote</a>
<a class="subheader__link" href="https://www.nwaonline.com/testbaeln2/" title="☑️ National Election Results ">☑️ National Election Results </a>
<a class="subheader__link" href="https://www.nwaonline.com/covidclassroomnw/" title="Covid Classroom">Covid Classroom</a>
<a class="subheader__link" href="https://www.nwaonline.com/coronavirus/" title="Coronavirus">Coronavirus</a>
<a class="subheader__link" href="https://www.nwaonline.com/news/2020/mar/12/list-northwest-arkansas-cancellations-and-postpone/" title="Cancellations">Cancellations</a>
<a class="subheader__link" href="https://www.nwaonline.com/news/2020/mar/27/sites-offer-virus-screenings-northwest-arkansas/" title="NWA Screening Sites">NWA Screening Sites</a>
<a class="subheader__link" href="https://www.nwaonline.com/arvirus/" title="Virus Interactive Map">Virus Interactive Map</a>
<a class="subheader__link" href="https://www.nwaonline.com/coronavirus/faq/" title="Coronavirus FAQ">Coronavirus FAQ</a>
<a class="subheader__link" href="https://www.nwaonline.com/crime/" title="Crime">Crime</a>
<a class="subheader__link" href="https://www.nwaonline.com/sports/razorbacks/" title="Razorback Sports">Razorback Sports</a>
<a class="subheader__link" href="http://nwamedia.photoshelter.com/" title="Today&#39;s Photos">Today&#39;s Photos</a>
<a class="subheader__link" href="https://www.nwaonline.com/puzzles/#puzzle,1468,1547479094084" title="Puzzles">Puzzles</a>
</div>
<main class="container">
<div class="ad-block-section">
<div class="ad-block">
<span class="ad">ADVERTISEMENT</span>
<div data-ad='div-gpt-ad-320x50'></div>
<div data-ad='div-gpt-ad-flex'></div>
</div>
</div>
<div class="article-header-2"><span class="most-recent-article-info">

<h1 class="most-recent-article-title" role="heading">Elizabeth J. Reagan </h1><span class="subhead">Fayetteville , AR, 1922 - 2020</span>

<span class="comments-and-share">
<a class="comments__number" href="#comments">
<span class="comments__icon">0</span>comment
</a>
<span class="share-section">

 
<div class="addthis_toolbox addthis_default_style addthis_16x16_style">
<a class="addthis_button_facebook"></a>
<a class="addthis_button_twitter"></a>
<a class="addthis_button_compact"></a><a class="addthis_counter addthis_bubble_style"></a>
</div>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":false};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4da255f70f1c3942"></script>

</span>
</span>
</span>
</div>
<div class="left-and-right-rail">
<div class="left-rail">
<div class="recommended obits">
<div class="">
<img class="obits__single-image" src="https://wehco.media.clients.ellingtoncms.com/img/obits/2020/11/21/elizabeth-reagan-1_jpg_t300.jpg?8aff03de2423e912a2467e97388a07f5331c05b6" alt="Photo of Elizabeth  J. Reagan " style="float: left; margin-right: 20px; margin-bottom: 20px; float: left;">
<div style="clear: left;"></div>
</div>
<div class="bcmeter">
<p>Elizabeth J. Reagan, age 98, passed on November 20, 2020. She was born to Clarence and Margaret Moore in St. Paul, Minn., on October 3, 1922. She earned her BSN from the University of Minnesota, and immediately put her education into practice by volunteering as a nurse in the NYC polio outbreak during WWII. She returned to the Twin Cities and married Robert M. Reagan in 1946. In 1947 became a full-time mother giving birth to the first of 13 children. </p><p>In 1950, the family moved from Minnesota to Albuquerque, N.M., then to Clarksville, Ark., finally settling in Fayetteville, Ark., in 1955. In 1956 they moved to a small farm on the south side of Fayetteville, into a house built by the builder of Old Main, known today as the Reagan Family Farm.</p><p>Some things most readers won&#39;t know about Elizabeth: She endeared herself to two retired neighbors, both farmers, from whom she and her family learned to grow a garden, plow and till a field, hand milk a cow, raise beef, chickens and hogs, build fence, put up hay and can vegetables. She was an exceptionally hard-working stay-at-home farm mother, still finding time to exercise her intellectual curiosity by attending university classes and doing her part for the community at large. </p><p>Subscribing early on to the writings of the health food enthusiasts (i.e. Rodale and Adele Davis), Elizabeth focused the farm on the practices now called regenerative agriculture. With the help of her children, Elizabeth was able to augment the family diet with home grown food from the farm. In this, as with many other things, she was ahead of her time. As a natural outgrowth of these practices, she held a deep care for the environment. A planted tree was a special joy to her. A felled tree was a lost battle, keenly felt. </p><p>Elizabeth describes herself as a doer; she was. </p><p>In the early 1970&#39;s she began auditing one class per semester at the U of A... Ben Kimpel (English Dept.) accepted her as an audit student. She took most of his courses. He directed her to other professors, in many disciplines. Her last course, Torts, was in the Law School. Over 45 years she accumulated ~250 audit hours. In 2017, the U of A Chancellor presented Elizabeth an inscribed class ring recognizing her continuous learning. </p><p>Elizabeth&#39;s curiosity must have had boundaries, but those were not readily visible. You can view a U of A video on Elizabeth by searching for &quot;Short Takes: In a Class of Her Own&quot; on YouTube.</p><p>The Reagan children remember their mother sitting at the old typewriter, once per week, ten-fingering a single-spaced, double-sided weekly journal. That journal is now available in Special Collections at the University of Arkansas Library. </p><p>Some of you will remember a woman walking the sidewalks of S. Fayetteville, the Square and Dickson Street with a plastic bag, picking up trash. That was Elizabeth on her way to or from her university class, in her small way sprucing up of Fayetteville streets. She served the public for several years as a member of the Fayetteville Parks and Recreation Advisory Board and on the NW Arkansas Free Health Center Board, now WelcomeHealth. </p><p>Besides walking from the farm to the University two or three times a week, Elizabeth ice skated. She loved ice skating, having grown up on ice in Minnesota. She spoke fondly of friendships she developed with fellow skaters and of the pure thrill she felt on ice. Donning her protective helmet and knee pads, she skated once or twice a week from the time the Jones Center opened until 2016. </p><p>Elizabeth opened her house and resources to anyone. She offered hot coffee or chocolate to the garbage collectors on cold days, cold water on hot days. When she could, she brought food to those without and drove those lacking transportation where they needed to go. She recognized neither class nor color. Some of the first black athletes at the University of Arkansas were welcomed into their first white home by Elizabeth. Sweet Pea &quot;Gary White&quot;, the first dancing Razorback, still calls for warm conversations with &quot;Mama Reagan&quot;	</p><p>Elizabeth was sometime saddened by the fact that she had outlived her contemporary friends. But she was braced, continually engaged and ever thankful for a group of younger women who were drawn to and communicated with her until her death. </p><p>In 2016, at age 93, Elizabeth announced to the family that she was quitting school and skating. Both had become too much of a challenge for her diminished driving ability. </p><p>Unable to be mentally and physically stimulated, her decline accelerated. She was lucky to have a daughter in Fayetteville, also a nurse, who cared for her as mobility declined. But she never lost her spark , humor or curiosity. She listened to Jeopardy religiously and, to her nurse&#39;s chagrin, demanded candy whenever handed vitamins. Her family and friends visited regularly in her final years.</p><p>Dying is not on anyone&#39;s wish list, but we all die. Some are lucky enough to have lived full and long and to have died in the care of family and friends. Elizabeth Reagan was one of those lucky people. Arguably a luck brought on by her many years of kindness.</p><p>Elizabeth Reagan&#39;s children, grandchildren and great-grandchildren are all living. The children are Robert, Paul, Mary, Daniel, David, Catherine, Peter, Joseph, Elizabeth, John, Ann, Bill and Jim. The grandchildren are Rachel, Philip, Kagan, Sean, Molly, Brian, Brad, Anders, Jonas, Jordan, Nate, Dillon, Emily, Katie and Zach. The great- grandchildren are Sophia, Maya, Zoey, Colton, Hadley, Harper, Hope, Etta, Everlee, Sawyer and Lillian.</p><p>At a future time, a memorial service will be held at the Reagan Family Farm.</p><p>Cremation arrangements are under the direction of Moore&#39;s Chapel in Fayetteville. </p><p>To place an online tribute, please visit <a href="http://www.mooresfuneralchapel.com" rel="nofollow">www.mooresfuneralchapel.com</a>.</p>
<p>Published November 22, 2020</p>
</div>
<p>
<span style="font-weight: bold;">OBITUARY SUBMITTED BY:</span><br />
Moore Chapel<br />
206 West Center Street, P.O. Box 1149, Fayetteville, AR<br />
Phone: 479-442-7314<br />
</p>

<h2>Comments</h2>
<div id="comments">
<div id="comment_form">
<p>Registration is required to make comments. <a href="https://auth.nwaonline.com/auth/forms/registered_login_nwa.php?d=www.nwaonline.com&amp;s=/obituaries/2020/nov/22/elizabeth-reagan-2020-11-22/#comment_form"><strong>Click here to LOGIN</strong></a>.<br />
You can <a href="http://www.nwaonline.com/accounts/register/">register for FREE</a> to post comments and receive alerts.</a></p>
</div>


</div>
</div>
</div>
<div class="add-position-top-mobile hide-for-desktop"><span class="ad">ADVERTISEMENT</span>
<div data-ad='div-gpt-ad-300x250-mobile'></div>
</div>
<div class="right-rail">
<div class="add-position-right"><span class="ad">ADVERTISEMENT</span>
<div data-ad='div-gpt-ad-300x250'>
</div>
</div>

<div class="add-position-right three-x-six hide-for-desktop"><span class="ad">ADVERTISEMENT</span>
<div data-ad='div-gpt-ad-300x600'></div>
</div>
</div>


</main>
<footer>
<div class="container footer"><img class="footer__logo" src="https://media.arkansasonline.com/static/nwa_redesign/dist/img/nwa-logo.png" alt="">
<nav class="footer__nav">
<div class="nav-list nav__footer-menu-item"><span class="nav__header-menu-text">NWADG<em class="caret fas fa-angle-down"></em></span>
<ul class="nav-submenu nav__footer-sub-menu">
<li><a href="/obituaries/" title="Obits">Obituaries</a></li>
<li><a href="/celebrations/" title="Celebrations">Celebrations</a></li>
<li><a href="/eventhub" title="Events">Events</a></li>
<li><a href="/nie/" title="NiE">NiE</a></li>
<li><a href="/advertising/" title="Advertise">Advertise</a></li>
</ul>
</div>
<div class="nav-list nav__footer-menu-item"><span class="nav__header-menu-text">Sports<em class="caret fas fa-angle-down"></em></span>
<ul class="nav-submenu nav__footer-sub-menu">
<li><a href="/sports/prep/" title="High School Sports">High school</a></li>
<li><a href="/sports/college/" title="College Sports">College</a></li>
<li><a href="/sports/pro/" title="Professional">Professional</a></li>
<li><a href="/outdoors/" title="Outdoors">Outdoors</a></li>
<li><a href="http://wholehogsports.com" title="Whole Hog Sports">Whole Hog Sports</a></li>
</ul>
</div>
<div class="nav-list nav__footer-menu-item"><span class="nav__header-menu-text">News/Opinion<em class="caret fas fa-angle-down"></em></span>
<ul class="nav-submenu nav__footer-sub-menu">
<li><a href="/arkansas/northwest/" title="Local News">Local News</a></li>
<li><a href="/arkansas/" title="State News">State News</a></li>
<li><a href="/national/" title="National News">National News</a></li>
<li><a href="/world/" title="World News">World News</a></li>
<li><a href="/opinion/northwest/" title="Local Opinion">Local Opinion</a></li>
<li><a href="/opinion/" title="All Opinion/Editorial">All Opinion/Editorial</a></li>
<li><a href="/email/" title="Newsletters">Newsletters</a></li>
</ul>
</div>
<div class="nav-list nav__footer-menu-item"><span class="nav__header-menu-text">Weeklies<em class="caret fas fa-angle-down"></em></span>
<ul class="nav-submenu nav__footer-sub-menu">
<li><a href="http://bvwv.nwaonline.com/" title="Bella Vista Weekly Vista">Bella Vista Weekly Vista</a></li>
<li><a href="http://www.eagleobserver.com/" title="Westside Eagle Observer">Westside Eagle Observer</a></li>
<li><a href="http://freeweekly.com/" title="The Free Weekly">The Free Weekly</a></li>
<li><a href="http://mdcp.nwaonline.com/" title="McDonald County Press">McDonald County Press</a></li>
<li><a href="http://www.laprensanwa.com/" title="La Prensa Libre">La Prensa Libre</a></li>
<li><a href="http://hl.nwaonline.com/" title="The Herald-Leader">The Herald-Leader</a></li>
<li><a href="http://tnebc.nwaonline.com/" title="Pea Ridge Times">Pea Ridge Times</a></li>
<li><a href="http://wcel.nwaonline.com/" title="Wash Co Enterprise Leader">Wash Co Enterprise Leader</a></li>
</ul>
</div>
<div class="nav-list nav__footer-menu-item"><span class="nav__header-menu-text">Multimedia<em class="caret fas fa-angle-down"></em></span>
<ul class="nav-submenu nav__footer-sub-menu">
<li><a href="/video/" title="Videos">Videos</a></li>
<li><a href="/photos/" title="Photos">Photos</a></li>
<li><a href="/photoreprints/" title="Purchase Prints">Purchase Prints</a></li>
<li><a href="/sponsorcontent/?ntv_adpz=3457" title="Ask An Expert">Ask An Expert</a></li>
<li><a href="/nwtablethelp/" title="Tablet Help">Tablet Help</a></li>
</ul>
</div>
<div class="nav-list nav__footer-menu-item"><span class="nav__header-menu-text">Contact<em class="caret fas fa-angle-down"></em></span>
<ul class="nav-submenu nav__footer-sub-menu">
<li><a href="/advertising/" title="Advertising">Advertising</a></li>
<li><a href="/tools/circulation/" title="Circulation">Circulation</a></li>
<li><a href="/customer_service/" title="Customer Support">Customer Support</a></li>
<li><a href="/staff/" title="Newsrooms">Newsrooms</a></li>
<li><a href="/staff/#submissions" title="Submission Forms">Submission Forms</a></li>
<li><a href="https://jobs.wehco.com/Application/Newspaper/Opportunities.aspx" title="Careers at the NWADG">Careers at the NWADG</a></li>
<li><a href="https://www.jobsarkansas.com/" title="Jobs Arkansas">Jobs Arkansas</a>
</li>
</ul>
</div>
</nav>
<div class="footer__links"><a class="default-link" href="/staff/" title="title">Contact Us</a><a class="default-link" href="/termsofuse/" title="title">Terms of Use</a><a class="default-link" href="/advertising/" title="title">Advertise With Us</a></div>
<p class="legal">Copyright &copy; 2020, Northwest Arkansas Newspapers LLC. (NWA Media)</p>
<p class="legal">All rights reserved.</p>
<p class="legal">This document may not be reprinted without the express written permission of Northwest Arkansas Newspapers LLC. Please read our <a href="//www.nwaonline.com/termsofuse/">Terms of Use</a> or <a href="//www.nwadg.com/staff/">contact us.</p>
<p class="legal">Material from the Associated Press is Copyright © 2020, Associated Press and may not be published, broadcast, rewritten, or redistributed. Associated Press text, photo, graphic, audio and/or video material shall not be published, broadcast, rewritten for broadcast or publication or redistributed directly or indirectly in any medium. Neither these AP materials nor any portion thereof may be stored in a computer except for personal and noncommercial use. The AP will not be held liable for any delays, inaccuracies, errors or omissions therefrom or in the transmission or delivery of all or any part thereof or for any damages arising from any of the foregoing. All rights reserved.</p>
</div>
</footer>


<script src="https://media.arkansasonline.com/static/nwa_redesign/dist/js/scripts.js"></script>
<script>
$("a.dsq-widget-thread").text(function () {
    return $(this).text().replace(" | NWADG", "");
});
            </script>
<script type="text/javascript">
  function getCookieValue(cname) {
    var name = cname + "=";
    var decodedCookie = decodeURIComponent(document.cookie);
    var ca = decodedCookie.split(';');
    for(var i = 0; i <ca.length; i++) {
      var c = ca[i];
      while (c.charAt(0) == ' ') {
        c = c.substring(1);
      }
      if (c.indexOf(name) == 0) {
        return c.substring(name.length, c.length);
      }
    }
    return null;
  }

  var _sf_async_config={uid:33131,domain:"nwaonline.com"};
  (function(){
    function loadChartbeat() {
      window._sf_endpt=(new Date()).getTime();
      var e = document.createElement('script');
      e.setAttribute('language', 'javascript');
      e.setAttribute('type', 'text/javascript');
      e.setAttribute('src',
        (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
        "js/chartbeat.js");
      document.body.appendChild(e);
    }

    var oldonload = window.onload;
    window.onload = (typeof window.onload != 'function') ?
      loadChartbeat : function() { oldonload(); loadChartbeat(); };
    var _cbq = window._cbq = (window._cbq || []);

    var cb_user_type = getCookieValue("cbVisitorStatus");
    if (cb_user_type !== null) {
      _cbq.push(['_acct', cb_user_type]);
    }
  })();

</script>

<script type="text/javascript">
(function() {
var ms = document.createElement('script'); ms.type = 'text/javascript'; ms.async = true;
ms.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') + '//magnetapi.klangoo.com/w/Widgets_324.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ms, s);
})();
</script>
</body>
</html>
